A normal user receives the error message "Value can not be null when Workspace Information Web Part. Parameter name: workspace element has not been found, "said an admin gets displayed correctly the data.. But this only occurs when more than 8 columns have been selected.
Reason:
SharePoint limits the query of columns on 8 columns in a CAML Query.
Solution:
By more than 8 columns display in the workspace information Part of the value "ListView Lookup Threshold" must be increased in Central Administration