Issue: User Cannot Save Personal Data in Teams Manager

Issue: User Cannot Save Personal Data in Teams Manager

Description:

A user reports that they are unable to save their personal data in Teams Manager. This issue occurs when the user is not present in the BotUser table in the database.


Root Cause:

The entry for the user in the BotUser database table was not automatically created. Without this entry, personal settings cannot be saved in Teams Manager.


Solution Steps:

  1. The user opens Microsoft Teams and navigates to the Teams tab.
  2. In the Teams tab, the user interacts with the Teams Manager Bot by sending a message using the prompt function (e.g., typing "Hi" or "Start").
  3. This interaction automatically creates the user entry in the BotUser table of the database.
  4. The bot will respond to the user in the chat, confirming successful registration.
  5. After this, the user should be able to save personal settings in Teams Manager without any issues.

Note:

This action only needs to be performed once per user, unless the BotUser entry is removed again from the database.

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